プログラミング 環境

【WordPress】PHP7.2→7.3でレイアウト崩れが発生した




しばらくサボっていたWordPressのメンテをしようと、各バージョンを上げました。

  • WordPress:5.6
  • PHP:7.4.4

そしたらトップページでレイアウト崩れ&500エラーが発生するようになり。。。
結論としてはプラグイン(Crayon Syntax Highlighter)のせいだったんですが、忘れそうなのでメモ。

トップページだけレイアウトが崩れる

これがPHP7.2の時。

PHP7.3以上に上げるとレイアウトが崩れてます。
Consoleを見ると500エラーが発生しています。
どうやらindexの1行目がダメらしいです。

アクセスログを見てみる

ブラウザだけだと何が起きているかわからないので、サーバー側のログを確認します。
サーバーはWordPress運用でよく使われるXSERVERです。

XSERVERの場合はサーバーに入ってもroot権限がなくてアクセスログやエラーログが見れません。
ではどうするかというと、ServerPanel > アクセス解析 > アクセスログから取得します。

アクセスログは何も設定していなくても1ヶ月分くらいは保存されています。
必要な日を指定してダウンロードボタンを押します。

UAを変えてアクセスログを探しやすくする

ダウンロードしたファイルには1日分のアクセスログが入っているわけですが、公開済みのサイトだと自分以外のアクセスもあって対象のログを探すのが大変です。
なので、User Agentをいじって目印を付けます。
以下Chromeでの設定方法です。

確認対象のWEBページを表示してF12を押し、Developer Toolを表示します。
歯車アイコンの横の︙ > More tools > Network conditionsをクリック。

Select automaticallyのチェックを外してUser agentに任意の文字列を入力。
これで対象のアクセスログのUAが指定した文字列になります。

で、対象のアクセスログがこれ。
確かに500を返してます。
他にCSSなどへのアクセスも来ていますが、そっちはすべて200を返していました。

なるほど…何が起きてるかさっぱりわからんw

エラーログを見てみる

アクセスログと同じようにエラーログをダウンロードします。
が、アクセスしたときにはエラーが発生してませんでした。

え、500なのに何もエラー吐いてないの…?
嘘でしょ…?

んなわけないと思いつつ、root権限なくて詳細が確認できないのでひとまず別の角度から調査を進めます。

レスポンスデータを見てみる

500エラーでエラー画面が表示されるならわかるけど、レイアウト崩れってどういうことだ?
ということで、サーバーが何を返してるかを確認します。

Developer ToolのNetworkで対象ファイルをクリック。
Responseタブを開くと、サーバーが返してきたHTMLのソースが見れます。

ソースを下まで見ていくと、トップページで記事のリストを作っているところでエラーが起きていました。
対象記事はFlutterについてのやつ。
試しにこのページを表示すると、確かにエラー画面になりました。

プラグインを確認してみる

対象がFlutterということは、心当たりはあいつしかいない…!!
コードを表示するためのプラグインCrayon Syntax Highlighterを無効化すると…直りました!!

このプラグイン、有名ではあるものの、もうずっとメンテされてないんですよね。。。
別のに変えたほうがいいのはわかっているものの、直すとなると既存記事を全部書き換えないといけないので放置してたやつです。。。

プラグイン変えるのはしんどいけど、エラーログ出ないのにデバッグするのも嫌だなぁ。
まぁ使ってる人多いから、だれか修正方法書いてるでしょ。
でググってみたらやっぱりヒット。

PHP7.2→7.3で正規表現の解釈が変わったのが原因とのこと。
修正はcrayon_langs.class.php 340行目を直せばOKです。

修正後にCrayon Syntax Highlighterを有効化してトップページを確認し、レイアウトが崩れないことを確認しました。

レンタルサーバーでの調査って大変

レンタルサーバーは手軽ですが、root権限ないとなかなか調査するのが難しいですね。。。
ログをtailしたくてもできないし。
エラー出てないわけないと思っても確認できないし。

最近流行りのVPSならroot権限があるところもあるみたいですが、サーバーを引っ越すのも大変なので悩むところ。
root権限あるとサーバーぶっ壊す可能性もあるわけで。
今のところroot権限あるVPSだとさくらのVPSが有名らしいので、興味がある人はチェックしてみてもいいかも。

まぁ、今回PHP7.4に上げたから当面は問題ないでしょう。
次上げるときは8系だから問題が大量発生しそうだけど、その時になったら考えよう。。。

-プログラミング, 環境
-,

© 2021 そんなこと猫でもできる Powered by AFFINGER5